Downtime
Incident Report for Agendrix
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 18, 2018 - 09:59 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 year ago. Jul 18, 2018 - 09:05 EDT
This incident affected: Web App.