Website down due to data center issues
Incident Report for Agendrix
Resolved
This incident has been resolved.
Posted 12 months ago. Aug 17, 2018 - 22:34 EDT
Update
We are continuing to investigate this issue.
Posted 12 months ago. Aug 17, 2018 - 22:33 EDT
Investigating
We are currently investigating this issue.
Posted 12 months ago. Aug 17, 2018 - 20:30 EDT
This incident affected: Website.