Website down
Incident Report for Agendrix
Resolved
This incident has been resolved.
Posted over 2 years ago. Mar 30, 2017 - 15:00 EDT
Investigating
Our website (not the app) is currently down. We're working with our hosting provider to work on a resolution.

Notre site Web (et non l'application) est actuellement indisponible. Nous travaillons avec notre fournisseur d'hébergement à régler le problème.
Posted over 2 years ago. Mar 30, 2017 - 14:46 EDT